Need Help with Scandisk and Defrag

TNC Discussion Board: General Discussion: Defrag: Need Help with Scandisk and Defrag
  Subtopic Posts   Updated


Top of pagePrevious messageNext messageBottom of pageLink to this message   By amxa5mz@mail.ru on Thursday, June 22, 2006 - 07:24 pm:

Authentication Error

Your username/password combination was invalid, or you do not have permission to post to this topic. You may revise your username and password using the form at the bottom of this page.

Top of pagePrevious messageNext messageBottom of pageLink to this message   By Thomas Eleam on Wednesday, April 18, 2001 - 01:53 pm:

Just completed a Dfrag without any problems. I used Norton's Utilities though. I didn't know I had the defrag function on that program. Seems like I found these things by stumbling over them when I really look into the program(s). :)

It didn't take as long as I thought. I guess what I wanted all along was to defrag my HD from time to time as I realize the importance of keeping it humming along and prolonging the life of it.

Yes I have "Data Life Guard" too. I do hope that I don't have to reinsall win98 at least in the near future until I can get a win98 CD.

Thank You very much for all your time and Help.
I really appreciate it.

Tom Eleam

Top of pagePrevious messageNext messageBottom of pageLink to this message   By Thomas Eleam on Wednesday, April 18, 2001 - 05:00 am:

Ok, I'll do a defrag like you suggested and let you know what happens.

Thank You

Tom Eleam

Top of pagePrevious messageNext messageBottom of pageLink to this message   By Josh Lowe on Wednesday, April 18, 2001 - 03:54 am:

Hey Tom,

Well you just turned my light bulb off! I am glad you looked at the my computer stuff. Evidently, the partition magic IS correcting the BIOS problem without the WD software installed. Like I said in an earlier post, I haven't ever used the software, but it seems to be pretty good.

Ok, then DON'T GO REFORMATTING YOUR DRIVE! I jumped the gun before getting you to check your hard drive info from Windows.

Here is what I am thinking is the problem: The drive IS being recognized properly in Windows, but not DOS. The DOS doesn't matter anyway. The partition magic software has installed some files that are evidently controlling the hard drive. Windows doesn't like foreign products having control of things, and that is most likely why it is giving the error message.

Windows expects your drive to only contain FAT32 partitions, which have the proper sizes setup and all of that stuff. When it sees the partition magic setup, it knows that isn't the standard, so it gives an error.

So....my suggestion: Don't do anything. Just ignore the error message scandisk is giving you. You shouldn't really have to run the complete scan .... doesn't really do anything except fix problems if you are having some. If/when those problems occur, use WD tools instead of the windows tools... it will correct problems better, and more than likely won't give you an error message. (Use Data Lifeguard Tools, which you may have, if not, get them here:
http://www.westerndigital.com/service/ftp/drives.html )

Now, if the error really bugs you, then you could reformat and reinstall everything, using the WD EZ-Install software. However, considering the two problems you mentioned in your last email, I don't think this is the best choice. I don't know if WD will answer that message board or not. And, unless you have a folder on your computer called "win98", you can't reinstall windows. And even if you do have that folder, you will need to download a utility to be able to get your CD-Key for reinstallation.

My advice: Ignore the error, curse micro$oft, and keep everything going like it is now.

My defrag information given earlier still applies.

Josh
http://www.dyno-mite.com

Top of pagePrevious messageNext messageBottom of pageLink to this message   By Thomas Eleam on Wednesday, April 18, 2001 - 02:04 am:

Josh,

This is just an after thought. Could I copy the entire windows directory onto a CD and use that?

Also I checked the my computer like you suggested and here is what I found:

Local Disk
Fat 32
Used space 4.79 GB I ignored the byetes reported as they are long numbers:)
Free Space 23.3 GB
Capacity 28.1 Gb

If I am reading this right it tell's me that windows recognizes my hard drive as 30 gigs.

Correct me if I am wrong.

Thanks again

Tom Eleam

Top of pagePrevious messageNext messageBottom of pageLink to this message   By Thomas Eleam on Wednesday, April 18, 2001 - 01:34 am:

Thank You Josh.

When he installed the HD he didn't use the disk that came with WD, now it looks like I am going to. Anopther slight problem before I go ahead, actually two:

I am deaf and WD does not have a ttdy phone set up. I have tried their message board for several days and I haven't heard an answer to my post. I have gotten more in one day from you and I thank you.

Second minor problem. Wayne changed my oeprating system from Win95 to Win98 and he used his CD. I do not have a copy of it, I do have however the setup Disk which I borrowed from a friend. Would this do?

I have backup my entire file using a shareware product which is very good and intend to registar it. The backup took 8 hours and five CD's. I bakeup to my CD rw drive. I do have two CD drives also.

Yes your right. My machine is an older one which has gone though a series of up grades..

Please let me know the next step. I am trying to let you know all the potential as well as the actual problems with my system so I can avoid more mistakes and can have full recovery just in case something goes wrong.

I even order Norton's Utilties. I have the old verson, but I think the knew one will do nicley.

Thanks again.

You have been a big help.


Tom Eleam

Top of pagePrevious messageNext messageBottom of pageLink to this message   By Josh Lowe on Tuesday, April 17, 2001 - 09:27 pm:

Ah ha! (Light bulb switches on)

That gave some good information.

The problem seems to be that your computer is a little older. Older computer cannot recognize disk drive sizes larger than 8gb without extra software, which is probably why your daughters ex-boyfriend used partition magic instead of regular Fdisk to setup the drive.

I think partition magic (i have never used it) will detect the proper size, but windows, dos, and your bios does not. Western Digital (i think) distributes a floppy disk with their hard drives. This disk helps "trick" the BIOS into reading the proper size. This is the ONLY way to work around this disk size problem without updating your bios (i don't recommend).

In fact, you can probably start up windows, double-click my computer, right-click on C drive, go to properties, and it will say that it's capacity is 8.45 gb, when it should say 30. Because the drive is not setup properly, windows cannot utilize the full size of the drive, and that is also why you get the error messages when running scandisk.

Now that I have given you the bad news, here is a little more on the way to fix the problem. These are general instructions because I don't have the WD program in front of me, so I can't be specific. If you are not sure of what you are doing, it may be best to take your computer to a shop to get it setup properly.

First, backup all of your important files and programs that you will want to save (don't back up your programs that you have installation disks for.)

Second, go to start/settings/control panel. Double-click add/remove programs. Click the startup disk tab. Create a windows startup disk.


WARNING: THE FOLLOWING WILL CAUSE YOU TO LOSE EVERYTHING ON YOUR HARD DRIVE! You will need to boot with the WD floppy disk that came with the drive and run the setup program. It may give you an error saying the disk is already formatted. If so, say OK, and just continue with the reformat and repartitioning of the drive.

If the program will NOT reformat and repartition, then run FDISK from dos and delete (option 3) partition 1. WARNING: THIS WILL CAUSE YOU TO LOSE EVERYTHING ON YOUR HARD DRIVE!

Once the drive has been reformatted and partitioned, the WD software should install a few nessesary peices of code to let the BIOS detect the hard drive properly. Just follow the onscreen instructions. After all is done, a reboot should have the drive detecting properly. You may need to reformat/partition using fdisk (boot using the startup disk).

Once all of the formatting is done, insert your windows cd and reinstall windows. Windows will not detect your free space properly, but your drive will be working properly.

I know... quite a mouthful. I haven't been extremely specific through the reinstallation because I think that can be discussed once you decide whether or not to do all of this. Something you may want to do is give WD a CALL and explain what is going on...they may be able to offer some insight and help with the BIOS fix.

WD Tech Support: (800) 275-4932
M-Th: 9 am - 6 pm CST
F: 9 am - 4 pm CST
Sat: 8 am - 11:45 am, 1 pm - 5 pm CST


If you have some other questions, repost. If you want to contact me direct, use this:
http://www.dyno-mite.com/cgi-bin/moreinfo.cgi

HTH

Josh Lowe
http://www.dyno-mite.com

Top of pagePrevious messageNext messageBottom of pageLink to this message   By Thomas Eleam on Tuesday, April 17, 2001 - 08:36 pm:

Josh,

Here are the results of fdisk:
Partition C 1
Status A
Type PRI DOS
Volume Label (nothing written)
Mbytes 28851
System Fat32
Usage 100%

Total Disk Space is 8056 Mbytes
(1mbyte=1048576bytes)

Since my post and before I read your reply I did run a BIOS check with the "Data Lifeguard software" that came with the HD. Here is a partial
message:
IDE Drive 1: Bios is not accessing the full capacity. System BIOS is NOT controlling your drives(s) properly:

the rest of the Log is all Greek to me:
Drive Default:
Cylinders 16383, heads 16, Sectors/Track 63,Total Sectors 58633344=Max LBA, capacity 30020MB

Drive Current:
Everything the same except total Sectors reported as: 16514064=Max CHS, Capacity 8455 MB
.......................................

Int 41 Physical:
The same information as shown in Drive Current expect CHS is C*H*S (astericks)
........................................

There is more, but the bottom line reports as
follows:
.........................................

Partition Table LBA 0
System Type FAT32 LBA
Beginning Cyl 0 Head 1 Sect 1
Ending Cyl 1022 Head 254 Sect 63
Previous Sectors 63
Total Sectors
59087007
End of Log.

Could it be that the CMOS was not set up properly as that was one of the error messages when I tried
Scan Disk in DOS Mode. It gave me three possiblities as to what could be wrong. LBA not enabled. (It is according to everything I found)
Not configured properaly...Maybe this could be it?
and not partioned correctly. I think it was partioned correctly. These error messages are from my understanding and not exactly what the DOS scan showed. Also reports that it was unable to read from the last cluster.

I will wait until I hear from you before I do anything else. If the Problem is with my BIOS which I think it is, how can I correct it?

Thanks Again

Tom Eleam

Top of pagePrevious messageNext messageBottom of pageLink to this message   By Josh Lowe on Tuesday, April 17, 2001 - 07:12 pm:

Hey Tom:

I believe I can help you out a little bit. Whenever partition magic is used, I think that it sets aside a small partition for itself and some system files. Windows Scandisk may be having problems with this extra partition. That is what I think is going on. As far as fixing the problem, I wouldn't worry about it. Definatly don't go doing something drastic like reformatting your drive again...that will cause you to lose everything. You shouldn't need to run a thorough(sp?) scan unless you are starting to get problems.

You can check to see if this extra partition exists by running fdisk. Just reboot your computer in msdos mode....at the C:>, type in "fdisk" without quotes and hit enter. (if that doesn't work, type "cd windows" [enter], "cd command" [enter], "fdisk" [enter]).

Ok, a menu will start up...choose YES for enabling large disk support. (hit enter)

Now, choose 4 to display partition information. (press enter)

The screen will show your partitions on your computer. You should see a C partition, and then probably an option to display logical drives in the extended partition...do that too. What you are looking for is a partition that is very small in size, or has a file system that is not FAT32. That would be the partition magic partition.

Catch all that? Hope so, if not, lemme know and I will try again.

For defrag, I believe you have something in your system running that you shouldn't, and that is keeping it from working. Right-click on your desktop and go to properties. Click the screensaver tab, and make sure that you have "NONE" selected as the screensaver. Now, reboot the computer in safe mode (reboot, press CTRL during boot, select safe mode from the options). Once booted, look in your taskbar (by the clock). You should only have the speaker icon and the clock there. If you have anything else, right-click on each, and choose exit, close, or disable.

Try running defrag again.

Hope this helps,

Josh Lowe
http://www.dyno-mite.com

Top of pagePrevious messageNext messageBottom of pageLink to this message   By Thomas Eleam on Tuesday, April 17, 2001 - 12:54 pm:

I hope that someone can help me. I have read all the posts and tried all the suggestions recomended and I still have this problem. This is my problem. Recently I brought a new hard drive. It was installed and partioned with partioned magic software ver4. I am using windows98, the hard drive is a Westen Digital 30.7 gig.

My daughter's ex boyfriend did the installation,partioned and formating. Since then he has moveed. To make a long story short here is my problem.

Scandisk in DOS Mode will not work, it reports an error message that states it cannpt read from the last cluster and terminates. It also reports that LBA may not have been enabled. I checked this and LBA is enabled. It also reports that the
hard drive may have been configured wrong
I checked this two. I ran a diagnostics that came with the hard drive, it reports no errors.

I am beginning to think that the partioned is wrong, and don't know what to do at this point short of reformating my hard drive.

Whenever I try to run scandisk in windows it can do a standard scan, but not a through scan which tests the surface. Also Defrag will work for 10% than it stops without completing.

I have tried everything that I can think of to get this to work properly and so far no luck.

Any help or suggestions would be deeply appreciated. WD tech dept is so slow, and I have yet to hear from them.

Tom Eleam


Add a Message


This is a public posting area. If you do not have an account, enter your full name into the "Username" box and leave the "Password" box empty. Your e-mail address is optional.
Username:  
Password:
E-mail:
Post as "Anonymous"

Administrator's Control Panel -- Board Moderators Only
Administer Page